IBM InfoSphere Guardium

Version 8.2
Server IP Mapping for IBM Licensing Metering Tool (ILMT)

This document describes how to get the Server IP list for each Guardium chargeable component.

PID 5725-A85 - IBM InfoSphere Guardium

CCs - IBM InfoSphere Guardium Database Activity Monitor group
The following chargeable components can be classified as belonging to an activity monitoring group that

possesses the same criteria for mapping server IPs.
e IBM InfoSphere Guardium Database Activity Monitor with Privileged User Auditing
e IBM InfoSphere Guardium Database Activity Monitor with Sensitive Objects Auditing
e IBM InfoSphere Guardium Database Activity Monitor with Comprehensive Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Standby Systems with Privileged User Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Standby Systems with Sensitive Objects Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Standby Systems with Comprehensive Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Data Warehouses with Privileged User Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Data Warehouses with Sensitive Objects Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Data Warehouses with Comprehensive Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Load Balancing with Privileged User Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Load Balancing with Sensitive Objects Auditing
e IBM InfoSphere Guardium Database Activity Monitor for Load Balancing with Comprehensive Auditing

How to map
All of the above IBM InfoSphere Guardium Database Activity Monitor auditing activity can be mapped to:
1. Normally the IBM InfoSphere Guardium Database Activity Monitor monitors activity using S-TAP. The S-TAP Status
report, accessed through Tap Monitor -> S-TAP -> S-TAP Status, shows the S-TAP Host (server IP) that the IBM
InfoSphere Guardium Database Activity Monitor is monitoring.

S-TAP Status

Aliases: OFF

S-TAP Host S-TAP Version DB Server Type Status Last Response Primary Hest Hame KTAP Installed TEE Installed
192165220 521066 DE2 Active 2010-053-24 11:28:42.0192.1658.3.104 Mo o
192165220 521066 IMFORMIEE Active 2010-053-24 11:28:42.0192.1658.3.104 Mo o
192165220 621066 MESEL Active 2010-053-24 11:28:42.0192.165.5.104 Mo Mo
1921658220 821066 MS=EL_MP Active 2010-03-24 11:28:42.0192.168.3.104 Mo Mo
1921658220 821066 ORACLE Active 2010-03-24 11:28:42.0192.168.3.104 Mo Mo
192165220 521066 SYBASE Active 2010-08-24 11:2842.01921658.5.104 Mo Mo
192165221 521066 MSS0L Active 2010-08-24 11:2542.01921658.7 214 Mo Mo
1921658 .2 2325 21066 MSSEL Active 2010-05-24 11:25:4201921658.7 214 Mo Mo
1921658 .2 2325 21066 MSSEL Active 2010-05-24 11:25:4201921658.7 214 Mo Mo
192165.7 107521086 DE2 Active 2010-05-24 11:2542.0192168.7.214 Mo i [u]
1921658.7.1075 21066 IMFORMIE Active 2010-05-24 11:2542.0192168.7.214 Mo Mo
1921658.7.1075 21066 MSSEL Active 2010-05-24 11:2542.0192168.7.214 Mo Mo
192.1658.7.1075.21066 MSSEL_MP Active 2010-053-24 11:2542.01921658.7 214 Mo o
192.1658.7.1075.21066 ORACLE Active 2010-053-24 11:2542.01921658.7 214 Mo o

() @ Records [ 1 o200 25 D O 1 69 |y |H B (M B/ o

2. Ifnotusing S-TAP, but instead using network inspection you can go to the console inspection engines and see the
Server IPs being monitored. Access by going to Administration Console -> Configuration -> Inspection Engines.
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Inspection Engine Configuration

Log Request Sgl String Log Sequencing D

Log Exception S5gl String Log Records Affected |:|

Log timestamp per second I:l Compute Awg. Response Time I:l

Inspect Returmed Data D Record Empty Sessions D
Farse XhL I:‘

Lagging Granulsrity | G0 M=, Hits per Returned Data (G4

Ignored Port=s List
Euffer Free nfa

Restart Inspection Engines ] [ Add Comiments ] [ Apply

O Hare =vwan too
Protocal Cracle
OB Cliert IPiMask 192168118 § 255,255,255 255
Fart 1000-50000
OB Serwer IPfMask 1892165215 5255255 255255
Active on startup

Exclude DB Client 1P []

[ Stop ][ Delete ][ Apply

Add Inspection Engine...

Note: Access reports, such as the DB Server List, accessed by going to View -> Access Map -> DB Server List, can be
used to show a listing of the server IPs for the database servers seen during a reporting period.

CC - IBM InfoSphere Guardium - Enterprise Integrator

How to map

IBM InfoSphere Guardium provides the ability, through Custom Domains, to define any tables of data uploaded to the appliance
from the customer’s environment. Thus, this is the same as defined for the IBM InfoSphere Guardium Database Activity Monitor
group, see above.

CC - IBM InfoSphere Guardium - Application End User Identifier

How to map

The application end user can be seen through the Access Tracking domain and using the Access Period Entity to query
Application User. The Access Period entity can be joined to other entities such as Client/Server to find the Server IP. Query
Builder can be used to produce a report for server IPs such as the following:

@) Query Builder - Mozilla Firefox: IBs Edition =JIoEd
- —
EntityList |~ ||8 Application End User Identifier - Server IPs @ [
_lAccess I=in Entity: Client/Server D Ao Count Add Distinct Sort by count
Period &= Query Fields
__|5e==ion 1 Seq. Ertity Adtribote Field Mode Order-by Sort Rank De=cend |
_IClient/Server F 1 Client'Server Sener P Walue |4 | v
—lsaL X ([M0) sdditien mede: (#AND (OR [ HAYING Query Conditions
__lcommand Entity Agg. Adtribute Operatar Ruriti rne Faram.
S obiect [] WHERE Access Periad - Application User | 15 NOT NULL [w]
—JField ¥
’ Delete ] [ Clone: ] [ Roles... ] [ Save ] ’ Back ]
Generate Tabular ] [ Regenerate ] [ Add to Pane... ] [ Add to My Mewr Reports ]
Done ! @
2
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Alternatively, use the same as defined for the IBM InfoSphere Guardium Database Activity Monitor group (see above), the lis
servers in scope are the relevant for this application as well.

CC- IBM InfoSphere Guardium - Data-Level Access Control

How to map

To find if a policy has been configured to use S-GATE, you can look at the policy rules and their actions by going to Tools ->
Policy Builder -> Selecting the Policy -> Edit Rules and then expanding the individual rules to see if S-GATE is part of the
Actions defined. If S-GATE rules are in use then the list of server IPs would then be one of the following:

If the S-GATE Policy Rules include specific Server IPs (or a group of IPs) — then these IPs are in scope

If the S-GATE Policy Rules have ‘ANY’ for Server IPs — use the Server IPs are defined for the IBM InfoSphere
Guardium Database Activity Monitor group (see above).

t of

Policy Builder
Policy Rules @
8, Privileged Users Monitoring (black list) ] —— || & &

[ Expand Al | [ colspsean || Select Al [ Unselectal | [ DelteSelected | [ CopyRules.. |
= - ||
,:,]D {3 8 [&] [F4 Exception Rule: SOL Error - Log
=L 1] 8 [l E5 Exception Rule: SQL Error - Alert on Risk Indicative errors
,ﬂD [Z] 8 [z] =6 Access Rule: All Activities - Log Full Details
=] D 3 [zl ET Access Rule: Sensitive Objects - Log Yiolation
.ﬂD L:] 8 [#] =% Access Rule: DML, Sensitive Objects - Alert
'5||:| [:] 8 [ =9 Access Rule: Grant Commands - Log INFO Violation
.ﬂD L:] 8 [ =10 Access Rule: DDL Commands - Log INFO Violation
=l ] 3 [a] = 11 Access Rule: Block the creation of a view for Pll data

Czt. Classif. Sew. Client IP Server [P Srz App. OB Mame OE User App. User Client IPfSre App /OB UseriServer IP/Swc. Nan
ANY AN i AN AN AHY AHY ANY AHY AN | =3
05 User Swo. Name Met Protocol Field Fattern HML Pattern OB Type Cliert M
ANY ANY ANY ANY ANY AN ORACLE AN
Object/C d ObjectField "229095  po pepl rt Min. Reset Guarartine b F
Clbjec‘t e B ii=] amman e (1= Affectad =] eplacaeme Poriad in. Res uar_a ne essage Aetion
Group Group Fattern  Character Ct.  Irt. rin. Template K
Threshold
CREATE
SCOTT.EMFP_FI VIEW AN ANY 1) AN * ANY 0 o 1] Default §=-GATE TERMIMATE
App Event Exists App Bvent Text “al. Ewent Type App Bwvent Hum. Val. App Event Oate Ewent User k
.l ANY ANY ANT AN AN (L]
£ ||

Acddd Access Rule. . J

[ A Exception Rule. . Fule Suggestion

Suggest from DB

Acled Extrusion Rule...

Fule min. ot Object Group min. ct.
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CC - IBM InfoSphere Guardium - Database Vulnerability Assessment
How to map

The list of datasources defined under Tools -> Datasource Definitions -> Security Assessment (Application Selection) will
provide the database server IPs being used.

(Note: when datasource presents just the hostname, you’d need to click the ‘Modify’ button to see its IP address for)

Datazource Builder

Application Selection @

Accass Policy

Audit Task

Change Audit System
Classifier

Custom Demain
[ratabase Analyzer
honitor Walues

r Assessment

et
Datazource Builder

Datasource Finder

System (192.168.2.135)_N_A,
System (1921682 248)_N_A,
System (192.168.2.641_N_2

System (192.168.7.107)_N_A,

CC- IBM InfoSphere Guardium - Database Protection Knowledgebase
How to map

This is the same as IBM InfoSphere Guardium — Database Vulnerability Assessment, see above.
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CC- IBM InfoSphere Guardium - Configuration Audit System for Database Servers

How to map

The configuration, as seen through Assess/Harden -> Change Reports -> Configuration for CAS Instances and CAS Instance
Config will display the list of server IPs.
CAZ Instances

Aliazes: OFF CB_Type: LIKE %
Host_Mame: LIKE % [MSTAMCE LIKE %
0% _Type:  LIKE %

Host Hame Template Content 0S5 Type DB Type Instance Hame

1921682248 idevlfasync LR I _A Swystem (192168 .2.243)
192 168 2 245 fetcipas s * LR _A Syatem (1921652 248)
192 168 2 245 FSCRIPTS  + LI _A Syatem (1921652 248)
192 168 2135 fdeviasync LR _A Syatem (1921652 135)
1921682133 fetcipas s * [IES I_& Syatem (192.168.2.133)
192168 2,133 F=CRIPTS + LI M_A&, Syatem (192.168.2.133)
192168 2,64 WICRIPTZ_DIR_PTRHSES + WM N .& Syatem (192.168.2.64)

1921687107 %SCRIPTE_DIR_PTMYES + WM Syatem (1921687 .107)

monecortlstoﬁofﬂﬂm %%L—.H'BE/@E’

CAS Instance Config

Aliazes: OFF  Host_Mame: LIKE %
O _Type: LIKE %

Host Hame Template Content 05 Type DB Type Instance Status Last Status Change
192 168 2 248 deviazync LI M_a System (192 168 2 243)Ensbled 2010-08-15 11:0%:29.0
192 168 2 248 letcpas zwed LI M_a System (192 168 2 243)Ensbled 2010-08-15 11:0%:29.0
192168 .2 248 Mvar Ampligregoasizoriptzinetezza_log_scan.zh LM M_A Systemn (192168 .2 2458 Enabled 2010-05-15 11:09:29.0
192 168 .2 248 dvar Amplaregoasizcriptstnysgl_datadic_owner.zh LM M_2 Systermn (1921682 248)Enabled 2010-08-15 11:09:29.0
192168 .2 248 Mvar Amplaregcasizoriptsizvbasze_logfile_scan.sh LM M_2 Systermn (1921682 2458)Enabled 2010-05-15 11:09:29.0
192168 .2 248 ivar Amplgregcasizoriptsioracle _logfile_scan.sh LM M_2 Systermn (1921682 2458)Enabled 2010-08-15 11:09:29.0
192 168 2 245 vartmplgregoasizoriptsisybase_sysdevice_type_testsh  UWX M_& System (192 168 2. 2458 Enabled 2010-05-15 11:09:29.0
192 168 2 245 varAmplgregoasizcriptsinysgl_logfile_scan.sh LM M_& System (192 168 2. 2451Enabled 201 0-05-15 11.09:23.0
192 168 .2 245 vartmplgregoasizoriptsidbZ _spm_log_path_group_test.sh UMK M_& System (192 168 2. 2458 Enabled 2010-05-15 11:09:29.0
192 168 2 245 varimpigregoasizcriptsidb? _get_dh_cfg.sh LIM® M_A& Systen (192 168 2 245)Enabled 2010-05-158 11:09:23.0
192 168 2 245 varAmpigregoasizoriptsinformiz:_logfile_scan.sh LIM® M_A& Systern (192 168 2 248)Enabled 2010-05-15 11:09:23.0
192 168 2 245 varimpigregoasizcriptzidb? _logfile_scan sk LIM® M_A& Systen (192 168 2 245)Enabled 2010-05-158 11:09:23.0
192168 .2 248 Mar Amplogregoasizoriptsteradata_put_web zh LM M_2 Systermn (1921682 2458)Enabled 2010-05-15 11:09:29.0
192 168 .2 248 dvar Amploregoasizcriptsinformiz_onstat zh LM M_2 Systermn (1921682 248)Enabled 2010-08-15 11:09:29.0
192168 2 248 var Amplareqgoasizoriptsizvbase_sysdevice_owner_test.shUMK M_2 Systermn (1921682 2458)Enabled 2010-05-15 11:09:29.0
192168 2 248 ~varAmpigregoasiecriptshostgresgl_conf.sh LM M_2 Systemn (192168 .2 248)Ensbled 2010-08-15 11:09:30.0
182 168 .2 245 dvartmplgregoasizeriptsinformix_rootpath_owner.sh LM M_& System (192 168 2. 2458 Enabled 2010-05-15 11:09:29.0
192 168 .2 245 vartmplgregoasizcriptsinetezza_conf.sh LM M_& System (192 168 2. 2451Enabled 201 0-05-15 11.09:23.0
182 168 2 245 dvartimplgregoeasizcriptsioracle _spoolmain_exists.sh LI M_& Systemn (192 168 2 245)Enabled 2010-05-15 11:09:29.0

192 168 2 245 varAimpigregoasizcriptsizybase_dsync_option_test.sh LIM® N A Systen (192 168 2 245)Enabled 2010-05-158 11:09:23.0

@ Qrecords [ 1_Jto200f 3OO 1 5 | H S E 520
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CC - IBM InfoSphere Guardium - Database and Sensitive Data Finder

How to map

The list of datasources defined under Tools -> Datasource Definitions -> Classifier (Application Selection) will provide the
database server IPs being used.
(Note: when datasource presents just the hostname, you’d need to click the ‘Modify’ button to see its IP address for)

Datazource Builder

Application Selection @

Accass Policy
Audit Task
Change Audit System

EC|aszifier

Custom Dromain
[Cratabasze Analyzer
Monitar Walues
Security Aszezsment

Mect

Datazource Builder

Datasource Finder

System (192.168.2.135)_N_A,
System (1921682 248)_N_A,
System (192.168.2.641_N_2

System (192.168.7.107)_N_A,

CC - IBM InfoSphere Guardium - Advanced Compliance Workflow Automation

How to map

IBM InfoSphere Guardium provides the ability, through Compliance Workflow Automation, to streamline the compliance
workflow process by consolidating the database activity that is uploaded to the appliance from the customer’s environment. Thus,
this is the same as defined for the IBM InfoSphere Guardium Database Activity Monitor group, see above.

CC - IBM InfoSphere Guardium - Entitlement Reports

How to map

The list of datasources that entitlement reviews have been run can be seen through View -> DB Entitlements -> (Select
database).
ORA SYSDBA and SYSOPER Accrts

Start Date: 2010-08-18 09:23:26 End Date: 2010-08-25 09:23:26
Aliszes:  OFF

Username ls Sysdba ls Sysoper Is External Password Datasource Hame SqlGuard Timestamp Count of ORA SYSDBA and SYSOPER Accnts

PID 5726-A86 - IBM InfoSphere Guardium - Central Manager and Aggregator
CC- IBM InfoSphere Guardium - Central Manager and Aggregator

How to map
This is the same as defined for the IBM InfoSphere Guardium Database Activity Monitor group, see above.
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PID 5725-A87 - IBM InfoSphere Guardium Database Vulnerability Assessment
Solution
CC- IBM InfoSphere Guardium Database Vulnerability Assessment Solution

How to map
This is the same as IBM InfoSphere Guardium — Database Vulnerability Assessment, see above.

PID 5725-A89 - IBM InfoSphere Guardium - Software Appliance

e  CC- IBM InfoSphere Guardium Database Activity Monitor with Privileged User Auditing - Virtual Machine Image
e CC- IBM InfoSphere Guardium Database Activity Monitor with Sensitive Objects Auditing - Virtual Machine Image
e CC- IBM InfoSphere Guardium Database Activity Monitor with Comprehensive Auditing - Virtual Machine Image

How to map
This is the same as defined for the IBM InfoSphere Guardium Database Activity Monitor group, see above.

PID 5725-A90 - IBM InfoSphere Guardium - Central Manager and Aggregator -

Software Appliance
CC- IBM InfoSphere Guardium - Central Manager and Aggregator - Virtual Machine Image

How to map
This is the same as defined for the IBM InfoSphere Guardium Database Activity Monitor group, see above.

PID 5725-A91 - IBM InfoSphere Guardium Vulnerability Assessment Solution -

Software Appliance
CC- IBM InfoSphere Guardium Vulnerability Assessment Solution - Virtual Machine Image

How to map
This is the same as IBM InfoSphere Guardium — Database Vulnerability Assessment, see above.

PID 5725-F32 - Processor InfoSphere Guardium Database Activity

Value Unit Monitoring Suite Software Appliance
A Guardium Suite bundle contains functions that are identical to itemized offerings. See the individual

offering above for instructions on how to determine the Server IP list.
e IBM InfoSphere Guardium Database Activity Monitor - Sensitive Objects Auditing
e IBM InfoSphere Guardium Central Manager and Aggregator
e IBM InfoSphere Guardium Application End User Identifier
e IBM InfoSphere Guardium Database and Sensitive Data Finder
e |IBM InfoSphere Guardium Data Level Access Control
e IBM InfoSphere Guardium Enterprise Integrator
e IBM InfoSphere Guardium Configuration Audit System for Database Servers
e IBM InfoSphere Guardium Entitlement Reports
e IBM InfoSphere Guardium Advanced Compliance Workflow Automation
e IBM InfoSphere Guardium Database Vulnerability Assessment
e IBM InfoSphere Guardium Database Protection Knowledgebase
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PID 5725-F33 - Processor InfoSphere Guardium Database Activity

Value Unit Monitoring Suite Hardware Appliance
A Guardium Suite bundle contains functions that are identical to itemized offerings. See the individual

offering above for instructions on how to determine the Server IP list.
e IBM InfoSphere Guardium Database Activity Monitor - Sensitive Objects Auditing
e IBM InfoSphere Guardium Central Manager and Aggregator
e IBM InfoSphere Guardium Application End User Identifier
e IBM InfoSphere Guardium Database and Sensitive Data Finder
e |IBM InfoSphere Guardium Data Level Access Control
e IBM InfoSphere Guardium Enterprise Integrator
e IBM InfoSphere Guardium Configuration Audit System for Database Servers
e IBM InfoSphere Guardium Entitlement Reports
e IBM InfoSphere Guardium Advanced Compliance Workflow Automation
e IBM InfoSphere Guardium Database Vulnerability Assessment
e IBM InfoSphere Guardium Database Protection Knowledgebase

PID 5725-F34 - Application InfoSphere Guardium Database Vulnerability

Instance Assessment Suite Software Appliance
A Guardium Suite bundle contains functions that are identical to itemized offerings. See the individual

offering above for instructions on how to determine the Server IP list.

e IBM InfoSphere Guardium Database Activity Monitor - Sensitive Objects Auditing
e IBM InfoSphere Guardium Central Manager and Aggregator

e IBM InfoSphere Guardium Application End User Identifier

e IBM InfoSphere Guardium Data Level Access Control

e IBM InfoSphere Guardium Enterprise Integrator

e IBM InfoSphere Guardium Advanced Compliance Workflow Automation

e IBM InfoSphere Guardium Database and Sensitive Data Finder

e IBM InfoSphere Guardium Configuration Audit System for Database Servers
e IBM InfoSphere Guardium Entitlement Reports

e IBM InfoSphere Guardium Database Vulnerability Assessment

e IBM InfoSphere Guardium Database Protection Knowledgebase

IBM InfoSphere Guardium 8.2 Licensed Materials — Property of IBM. © Copyright IBM Corp. 2011. All Rights Reserved. U.S. Government Users Restricted Rights - Use,
duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

IBM, the IBM logo, and ibm.com are trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might
be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at www.ibm.com/legal/copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Other company, product or service names may be trademarks or service marks of others.
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